Enhance the performance and reliability of our cloud infrastructure

Scheduled for Apr 28, 22:00 UTC  -  Apr 29, 00:00 UTC

Update

We will be undergoing scheduled maintenance during this time.
Posted Apr 21, 2026 - 20:33 UTC

Scheduled

Customer Impact: As part of our ongoing efforts to enhance the performance and reliability of our cloud infrastructure, we will be performing a scheduled maintenance operation. We do not expect any downtime during this window.

Thank you for your understanding and continued support.
Posted Apr 21, 2026 - 20:05 UTC
This scheduled maintenance affects: DOOH (DOOH: Web Application & APIs, DOOH: DSP Edge Services, DOOH: SSP Edge Services, DOOH: AdServer Edge Services, DOOH: Header Bidder Edge Services, DOOH: Data Pipeline & Reporting).